summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorNecoro <>2008-01-18 01:36:13 +0000
committerNecoro <>2008-01-18 01:36:13 +0000
commit53f4e6ccd74d217409ec38b506d7e7e4aeb7d738 (patch)
tree6e836c58f8a3a6b715dc9ea0aa2c300218b00e01 /setup.py
parent9fbebc55eae3efabaeeab9d2d25a3952eccba51f (diff)
downloadportato-53f4e6ccd74d217409ec38b506d7e7e4aeb7d738.tar.gz
portato-53f4e6ccd74d217409ec38b506d7e7e4aeb7d738.tar.bz2
portato-53f4e6ccd74d217409ec38b506d7e7e4aeb7d738.zip
r643@Devoty: necoro | 2008-01-16 18:55:49 +0100
Fixed small bug in PackageTable.cb_package_revert_clicked r646@Devoty: necoro | 2008-01-18 00:12:30 +0100 Make tabpositions being configurable by the user r647@Devoty: necoro | 2008-01-18 01:38:19 +0100 Renamed 'shm' to '_shm' to not hide the global one r648@Devoty: necoro | 2008-01-18 01:38:29 +0100 Renamed 'shm' to '_shm' to not hide the global one r649@Devoty: necoro | 2008-01-18 02:34:43 +0100 Added update queues; general UI improvement
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 3 insertions, 3 deletions
diff --git a/setup.py b/setup.py
index 246d325..3b4bb36 100644
--- a/setup.py
+++ b/setup.py
@@ -127,14 +127,14 @@ def ui_file_list ():
uis = [x for x in os.listdir("portato/gui/templates/ui/") if x.endswith(".ui")]
return [os.path.join("portato/gui/templates/ui",x) for x in uis]
-packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage", "portato.backend.catapult", "portato.shm"]
-ext_modules = [Extension("portato.shm.shm", ["shm/shmmodule.c"], define_macros = MacrosAndDefines, extra_compile_args=["-fPIC"])]
+packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage", "portato.backend.catapult", "portato._shm"]
+ext_modules = [Extension("portato._shm.shm", ["_shm/shmmodule.c"], define_macros = MacrosAndDefines, extra_compile_args=["-fPIC"])]
data_files = [
(ICON_DIR, ["icons/portato-icon.png"]),
#(PLUGIN_DIR, plugin_list("shutdown", "resume_loop")),
(DATA_DIR, ["plugin.xsd"])]
cmdclass = {}
-package_dir = {"portato.shm" : "shm"}
+package_dir = {"portato._shm" : "_shm"}
if "gtk" in FRONTENDS:
packages.append("portato.gui.gtk")