summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2008-02-29 00:18:22 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2008-02-29 00:18:22 +0100
commit62fa03b7c712fbeab9d0d191e9f7cd22a3c1a0e6 (patch)
tree6971557011d505cf698a1518c6dc2696b6a31810 /setup.py
parent7c1842b22c68d7e0978859ea173a5cf719cbb40b (diff)
downloadportato-62fa03b7c712fbeab9d0d191e9f7cd22a3c1a0e6.tar.gz
portato-62fa03b7c712fbeab9d0d191e9f7cd22a3c1a0e6.tar.bz2
portato-62fa03b7c712fbeab9d0d191e9f7cd22a3c1a0e6.zip
Applied split
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py11
1 files changed, 1 insertions, 10 deletions
diff --git a/setup.py b/setup.py
index 3b4bb36..a9bfb4a 100644
--- a/setup.py
+++ b/setup.py
@@ -122,11 +122,6 @@ def plugin_list (*args):
"""Creates a list of correct plugin pathes out of the arguments."""
return [("plugins/%s.xml" % x) for x in args]
-def ui_file_list ():
- """Returns the list of *.ui-files."""
- uis = [x for x in os.listdir("portato/gui/templates/ui/") if x.endswith(".ui")]
- return [os.path.join("portato/gui/templates/ui",x) for x in uis]
-
packages = ["portato", "portato.gui", "portato.plugins", "portato.backend", "portato.backend.portage", "portato.backend.catapult", "portato._shm"]
ext_modules = [Extension("portato._shm.shm", ["_shm/shmmodule.c"], define_macros = MacrosAndDefines, extra_compile_args=["-fPIC"])]
data_files = [
@@ -138,11 +133,7 @@ package_dir = {"portato._shm" : "_shm"}
if "gtk" in FRONTENDS:
packages.append("portato.gui.gtk")
- data_files.append((DATA_DIR, ["portato/gui/templates/portato.glade"]))
-
-if "qt" in FRONTENDS:
- packages.append("portato.gui.qt")
- data_files.append((os.path.join(DATA_DIR,"ui"), ui_file_list()))
+ data_files.append((DATA_DIR, [os.path.join("portato/gui/templates",x) for x in os.listdir("portato/gui/templates") if x.endswith(".glade")]))
# do the distutils setup
setup(name="Portato",