summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.eu>2022-09-23 00:38:05 +0200
committerRené 'Necoro' Neumann <necoro@necoro.eu>2022-09-23 00:38:05 +0200
commit10f3b236022a8f93f26897f4184a4d84d86adba7 (patch)
tree697a30f61bb0d9c6994a9e25c0da6c2409718e87
parent27ca0dd02907c6c1e14f3857672553c4ab2d5eac (diff)
downloadsieve-app-bin-10f3b236022a8f93f26897f4184a4d84d86adba7.tar.gz
sieve-app-bin-10f3b236022a8f93f26897f4184a4d84d86adba7.tar.bz2
sieve-app-bin-10f3b236022a8f93f26897f4184a4d84d86adba7.zip
Remove desktop file being installed twice
-rw-r--r--PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 1b72bec..98fe9c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -17,13 +17,13 @@ sha256sums=('8b146c4681d6395c146d20e6337db6ad58d098bf6621b7c79d48cc81d7c82abe'
package() {
install -d -m0755 "${pkgdir}/"{opt/"${_appname}",usr/bin}
+ install -D -m0644 "${_appname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
# the contents of the source file are extracted directly at the top level...
- # thus, remove the zip so we can install the rest
- rm "${_zip}"
+ # thus, remove the sources so we can install the rest
+ rm ${source[@]##*/}
cp -a --no-preserve=ownership * "${pkgdir}/opt/${_appname}"
chmod -R o+rX "${pkgdir}/opt/${_appname}"
ln -s "/opt/${_appname}/sieve" "${pkgdir}/usr/bin/sieve"
- install -D -m0644 "${_appname}.desktop" "${pkgdir}/usr/share/applications/${_appname}.desktop"
}