summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRené 'Necoro' Neumann <necoro@necoro.net>2010-03-19 03:19:22 +0100
committerRené 'Necoro' Neumann <necoro@necoro.net>2010-03-19 03:19:22 +0100
commit33a162ec97deacfba497638836f91478fb0e9406 (patch)
tree10f0e7bc9699efadfe53a9cf4efa042376e60a9a
parentb9a237c62c9f786eb5264b37f38fdde30be21fba (diff)
downloadoverlay-33a162ec97deacfba497638836f91478fb0e9406.tar.gz
overlay-33a162ec97deacfba497638836f91478fb0e9406.tar.bz2
overlay-33a162ec97deacfba497638836f91478fb0e9406.zip
Bumped app-text/highlight
-rw-r--r--app-text/highlight/Manifest2
-rw-r--r--app-text/highlight/highlight-2.15.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/highlight/Manifest b/app-text/highlight/Manifest
new file mode 100644
index 0000000..1b92faf
--- /dev/null
+++ b/app-text/highlight/Manifest
@@ -0,0 +1,2 @@
+DIST highlight-2.15.tar.bz2 534401 RMD160 17c863f251c0e80fa210beb05b107f922d051264 SHA1 a431afe458c2c2cb63a0e4e49af089dc501050b8 SHA256 1d6be1d5e7e618db36d472fc726726a0012fb45a8a41f5b3498be3bd48bbc985
+EBUILD highlight-2.15.ebuild 1517 RMD160 21a915dd2a952a5ca48f73a56296e90e430563f5 SHA1 d9f63138ef8d886175746e318058f9edc6b28565 SHA256 391a76ab7164fe4b44f78149a56509d5325213585b41449f03bbc3ee8d435012
diff --git a/app-text/highlight/highlight-2.15.ebuild b/app-text/highlight/highlight-2.15.ebuild
new file mode 100644
index 0000000..b227759
--- /dev/null
+++ b/app-text/highlight/highlight-2.15.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-text/highlight/highlight-2.9.ebuild,v 1.7 2010/03/11 18:15:18 hwoarang Exp $
+
+EAPI=3
+inherit eutils toolchain-funcs
+
+DESCRIPTION="converts source code to formatted text ((X)HTML, RTF, (La)TeX, XSL-FO, XML) with syntax highlight"
+HOMEPAGE="http://www.andre-simon.de"
+SRC_URI="http://www.andre-simon.de/zip/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~hppa ppc ~sparc x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="qt4"
+
+RDEPEND="qt4? ( x11-libs/qt-gui:4
+ x11-libs/qt-core:4 )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e 's:-O2::' -e 's:CFLAGS:CXXFLAGS:g' \
+ -e 's:qmake-qt4:${EPREFIX}/usr/bin/qmake:' \
+ src/makefile || die "sed failed"
+}
+
+src_compile() {
+ emake -f makefile PREFIX="${EPREFIX}/usr/" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" \
+ || die "emake failed"
+
+ if use qt4; then
+ emake -j1 -f makefile PREFIX="${EPREFIX}/usr/" conf_dir="${EPREFIX}"/etc/highlight/ CXX="$(tc-getCXX)" gui \
+ || die "emake gui failed"
+ fi
+}
+
+src_install() {
+ dodir /usr/bin
+
+ emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr/" conf_dir="${EPREFIX}"/etc/highlight/ \
+ install || die "emake install failed"
+
+ if use qt4; then
+ emake -f makefile DESTDIR="${D}" \
+ PREFIX="${EPREFIX}/usr/" conf_dir="${EPREFIX}"/etc/highlight/ \
+ install-gui || die "emake install-gui failed"
+ doicon src/gui-qt/${PN}.xpm
+ domenu ${PN}.desktop
+ fi
+}