summaryrefslogtreecommitdiff
path: root/net-im/prosody/prosody-0.7.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/prosody/prosody-0.7.0.ebuild')
-rw-r--r--net-im/prosody/prosody-0.7.0.ebuild4
1 files changed, 4 insertions, 0 deletions
diff --git a/net-im/prosody/prosody-0.7.0.ebuild b/net-im/prosody/prosody-0.7.0.ebuild
index 25a8902..97229aa 100644
--- a/net-im/prosody/prosody-0.7.0.ebuild
+++ b/net-im/prosody/prosody-0.7.0.ebuild
@@ -43,11 +43,15 @@ src_prepare() {
}
src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
./configure --prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-lib=/usr/$(get_libdir)/lua \
--c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
+ --cflags="${CFLAGS}" \
+ --ldflags="${LDFLAGS}" \
--require-config || die "configure failed"
}