summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.7.0.ebuild4
2 files changed, 5 insertions, 1 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index b3a4c61..d8f346e 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -2,4 +2,4 @@ AUX prosody-0.6.2-cfg.lua.patch 637 RMD160 b3bdeaffbb8318debd9e99d006451ae9fb3cb
AUX prosody-0.7.0-cfg.lua.patch 1517 RMD160 ea1e8459c61d93e1b196177a42f089e153c79f8e SHA1 635bdc90428249d5846eabaf7cb8bac975dee3c5 SHA256 5bc54faaf365be5a3568f201fa53f0ff094bb51bb4d8300cdca60ec8aaffb4e8
AUX prosody.initd 1148 RMD160 54de6d4b97600024cfd8624fa10240a1e0a430e8 SHA1 c75e361c36e27adc880517d02a0e3089f200fd97 SHA256 e520a55d4a10fc7fce24ce7b57e722846d2814e6726407acba606af519de19e8
DIST prosody-0.7.0.tar.gz 177412 RMD160 2e40b4f807b6120971c611f52d4df3264a82cbb9 SHA1 3f3a6c4f262a062a9c027cc843cd6827104fb8ba SHA256 a8b826805dd55282706c5683c2028899b3721eb0f84d3e35c0509a6c1bc32390
-EBUILD prosody-0.7.0.ebuild 1912 RMD160 24bb7edaa7b057e1495507ba3d1f90032e4585df SHA1 d9ef0b34ba58ce002e43fe4be9cd3f3bb857a963 SHA256 6cc304b0ae6237527ed47e32612050bf878701e13de95826f25a1ad458370b7a
+EBUILD prosody-0.7.0.ebuild 2062 RMD160 94a341b82b0815f2093a81604e9292ce65517564 SHA1 157c7b1fd9d6b4d9b0728b25a985d6afe825b746 SHA256 aa20175e940a720f359074bb9b368942210c37b62f260d7c21490c35bceb8ebc
diff --git a/net-im/prosody/prosody-0.7.0.ebuild b/net-im/prosody/prosody-0.7.0.ebuild
index 25a8902..97229aa 100644
--- a/net-im/prosody/prosody-0.7.0.ebuild
+++ b/net-im/prosody/prosody-0.7.0.ebuild
@@ -43,11 +43,15 @@ src_prepare() {
}
src_configure() {
+ # the configure script is handcrafted (and yells at unknown options)
+ # hence do not use 'econf'
./configure --prefix="/usr" \
--sysconfdir="${JABBER_ETC}" \
--datadir="${JABBER_SPOOL}" \
--with-lua-lib=/usr/$(get_libdir)/lua \
--c-compiler="$(tc-getCC)" --linker="$(tc-getCC)" \
+ --cflags="${CFLAGS}" \
+ --ldflags="${LDFLAGS}" \
--require-config || die "configure failed"
}